Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
HaydenBarca

Registered:
Posts: 174
Reply with quote  #1 
This is a scripted (GM-less) mission that I created with my son (there may be a bit of silliness buried in there).  The basic plot is that a Ximni scout ship has gone missing and the crew needs to find it.  Be forewarned that this is not a carnage-fest combat mission -- more of a mystery and exploration focus.

It's good for beginners and features something for each of the main stations to do throughout (no specific fighter content).  This is my first attempt at a mission script, so I'd appreciate any feedback folks have on script design.  I playtested it pretty thoroughly, but if you notice something please let me know.

zip MISS_RescueTeam.zip     
(updated on 12/1/18)

Enjoy!

Mike Substelny

Avatar / Picture

Administrator
Registered:
Posts: 2,401
Reply with quote  #2 
Good timing, HaydenBarca! With the Thanksgiving holiday here in the US a lot of families will be looking for games to play together.

I will invite the gang coming to my Thankstgiving to try out your script. Thanks!

__________________
"The Admiralty had demanded six ships; the economists offered four; and we finally compromised on eight."
- Winston Churchill
HaydenBarca

Registered:
Posts: 174
Reply with quote  #3 
Glad you liked it and thanks for taking the time to give feedback.
HaydenBarca

Registered:
Posts: 174
Reply with quote  #4 
I realized that I hadn't reset the player ship starting position to it's correct place (from my playtesting).  It's fixed now in the original post.
Swede

Registered:
Posts: 56
Reply with quote  #5 
Good job both of you, us Swedes had a blast

Not many scripted missions around to find (and tips?) so happy to be inspired to do the same with my kid at some point..
SteampunkSkunk

Registered:
Posts: 17
Reply with quote  #6 

I just downloaded this as I was hoping to run it at a convention over Easter.  any chance of updating it to 2.7.1?  I just tried it at 2.7.1 and found the wrecked ship.  I could only scan it once (not twice as it prompts) and coms could get nothing from it.

 

Failing that anybody got a link to the 2.7 patch?

HaydenBarca

Registered:
Posts: 174
Reply with quote  #7 
Huh, I just tested it on 2.7.1 and it worked fine.  Just in case I missed an upload-after-edit, here is the file again.  Note that you have to get pretty close to the wreck before the Comms button becomes available.  Let me know if this works for you.

 
Attached Files
zip MISS_RescueTeam.zip (7.13 KB, 17 views)

SteampunkSkunk

Registered:
Posts: 17
Reply with quote  #8 
The new file is a different size to the old one so im guessing it is different.  I will try it now and let you know.  Thanks
SteampunkSkunk

Registered:
Posts: 17
Reply with quote  #9 

Im sorry to say I have exactly the same problem

-North of the black hole i find a purple dot labelled 'debris'

-I scan it once and find out its a wreck with a distress beacon

- I cant scan it a 2nd time (but the science info tells me I need too)

- Comms cant talk to it (i got so close that i hit it)

HaydenBarca

Registered:
Posts: 174
Reply with quote  #10 
Here's an updated version of Rescue Team that addresses some bugs, makes the messages more station-centered (e.g. just to Helm instead of to everyone), and updates to 2.7.5.  We also added randomization to three different scenarios and a completion timer for some replayability.

Updated 6/5/2020 with some bug fixes.  Thanks to Mike for the TopSpeed at 0.00001 idea.

 
Attached Files
zip MISS_RescueTeam.zip (8.26 KB, 0 views)

HaydenBarca

Registered:
Posts: 174
Reply with quote  #11 
Quote:
Originally Posted by SteampunkSkunk

Im sorry to say I have exactly the same problem

-North of the black hole i find a purple dot labelled 'debris'

-I scan it once and find out its a wreck with a distress beacon

- I cant scan it a 2nd time (but the science info tells me I need too)

- Comms cant talk to it (i got so close that i hit it)



So I've realized in building my Artemis scripting knowledge that on Science you can scan an object any number of times by hitting Enter, but the on-screen scan button only allows twice.  I've fixed this specific problem so it should work now. 

There's still some weirdness around scan levels 0, 1, and 2, and how being near to an object give you a free scan level, and maybe generic meshes are different in scans.  But between all of those factors I'm not sure exactly how scan levels work a priori, but I can fiddle with the dials enough to get it to work for a specific case.  Seems worth an experiment to pin this down.
ryleyra

Registered:
Posts: 2,986
Reply with quote  #12 
That's interesting. I don't think Thom ever intended for anything to be scanned more than twice (with the first being automatic if you get in visual range) but apparently while he disabled the scan button to prevent subsequent scans, the keybind is not disabled.

Do you know if the scan level continues to be incremented, or if it has a maximum value of 2? (You should now be able to read it with get_object_property) It is somewhat limiting to have a script depend on a keypress that has no on screen counterpart, but it does add some new functionality.

Alternately, you can just have the ship attach a tag to it. That's the intended method of adding an additional "scan level".
HaydenBarca

Registered:
Posts: 174
Reply with quote  #13 

I still have a note to self to conduct some scanning experiments for different objects and scan levels, but I haven't yet.  However, I did turn the Rescue Team mission into a GMed mission for a recent "local" virtual con game.  Specifically there's a part where the players can send some of their members on an "away mission" by switching their computer view over to Discord where I have my ArteLARP bot:
https://artemis.forumchitchat.com/post/away-missions-10518851?pid=1311490253

Then when they find a certain object on the away mission, the GM hits the button that gives them to clue to continue their search in Artemis.  It was my first proof of concept for the Away Mission Bot and it worked as expected (with the exception of the TopSpeed=0 error that Mike helped me fix).  I've attached it here in case anyone wants to look at it (though you would need the bot and more notes to actually do it yourself -- let me know if there's any interest to pull them togethre).

I've also updated the original GM-free mission three posts above this one.

 
Attached Files
zip MISS_Module_RescueTeamCon.zip (8.68 KB, 2 views)

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.