Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 1 of 2      1   2   Next
Tobias Cormano

Registered:
Posts: 7
Reply with quote  #1 
Somewhat major bug found: For me, at least, Artemis 2.0 will not run in current versions of Wine. I attempted to run it using Wineskin, PlayOnMac and Crossover; all three emulators successfully installed the program, but when starting Artemis, they either only got as far as the "Opening dat/" screen (Crossover) or failed to start entirely (PlayOnMac and Wineskin).

Update: PlayOnMac successfully ran 2.0 for me after I reinstalled it following these instructions exactly.

Error encountered, according to Crossover, was as follows:


Unhandled exception: page fault on read access to 0x067f11fc in 32-bit code (0x004ca780).
Register dump:
 CS:001b SS:0023 DS:0023 ES:0023 FS:1007 GS:000f
 EIP:004ca780 ESP:0033f918 EBP:0033f920 EFLAGS:00010616(  R- -- DI   -A-P- )
 EAX:067f1200 EBX:02c2ff10 ECX:019fc480 EDX:00000000
 ESI:067f11fc EDI:0944c03c
Stack dump:
0x0033f918:  02c2fee8 02c30020 00000000 00422333
0x0033f928:  02c5ae40 00000000 067f1200 2e122292
0x0033f938:  02c2fee8 0033f9a4 02c2fff0 02c30020
0x0033f948:  0033f970 004eaf4b ffffffff 0041facd
0x0033f958:  2e1222f6 00000000 0033f9a4 0033fb94
0x0033f968:  02c2fee8 02c2fee8 0033fb84 004eb39b
0200: sel=1007 base=7ffc0000 limit=00000fff 32-bit rw-
Backtrace:
=>0 0x004ca780 in artemis (+0xca780) (0x0033f920)
0x004ca780: repe movsl    (%esi),%es%edi)
Modules:
Module    Address            Debug info    Name (35 modules)
ELF           0-82001000    Stabs           <wine-loader>
PE      400000-  5fd000    Deferred        artemis
PE      600000-  838000    Deferred        d3dx9_24
PE    10000000-10039000    Deferred        ftd2xx
PE    401a0000-401a8000    Deferred        winspool
PE    40590000-4059e000    Deferred        setupapi
PE    40710000-40717000    Deferred        gdi32
PE    407d0000-407d4000    Deferred        version
PE    41f10000-41f14000    Deferred        advapi32
PE    41f70000-41f74000    Deferred        rpcrt4
PE    41fe0000-41fea000    Deferred        mpr
PE    44fb0000-44fea000    Deferred        user32
PE    45210000-45227000    Deferred        wininet
PE    45280000-45288000    Deferred        shlwapi
PE    452e0000-45439000    Deferred        shell32
PE    454f0000-4551e000    Deferred        comctl32
PE    455e0000-455e4000    Deferred        ws2_32
PE    45620000-45624000    Deferred        msvcrt
PE    456a0000-456a4000    Deferred        dsound
PE    456e0000-45752000    Deferred        winmm
PE    45790000-45798000    Deferred        ole32
PE    45910000-45914000    Deferred        winex11
PE    45a70000-45a77000    Deferred        wineps
PE    45b00000-45b03000    Deferred        usp10
PE    45b40000-45b44000    Deferred        imm32
PE    45b60000-45b64000    Deferred        d3d9
PE    45b90000-45b94000    Deferred        wined3d
PE    45cc0000-45cc4000    Deferred        opengl32
PE    46790000-46793000    Deferred        wineosxime
PE    467b0000-467b4000    Deferred        mmdevapi
PE    47490000-47493000    Deferred        winecoreaudio
PE    4a910000-4a918000    Deferred        oleaut32
PE    4ca40000-4ca44000    Deferred        iphlpapi
PE    7b810000-7b867000    Deferred        kernel32
PE    7bc10000-7bc14000    Deferred        ntdll
Threads:
process  tid      prio (all id:s are in hex)
00000008 winewrapper.exe
    00000009    0
0000000c services.exe
    0000001e    0
    0000001d    0
    00000017    0
    00000016    0
    00000015    0
    00000013    0
    0000000e    0
    0000000d    0
00000010 winedevice.exe
    0000001b    0
    00000018    0
    00000012    0
    00000011    0
00000019 plugplay.exe
    0000001f    0
    0000001c    0
    0000001a    0
00000020 (D) C:\Program Files\Artemis\Artemis.exe
    00000026   15
    00000024    0
    00000021    0 <==
00000022 explorer.exe
    00000023    0
System information:
    Wine build: wine-1.5.15-7123-gd00a241
    Platform: i386
    Host system: Darwin
    Host version: 11.4.2


Machine:
MacBook Pro, OSX Lion 10.7.5
2.3 GHz quadcore Intel i7 processor
8 GB RAM, 52 GB storage.

Judging by this post on WineHQ, at least one other person has experienced this issue.

Two other small things: One: the first time I tried to start the game using Crossover, I heard a snippet of the title music before it crashed. Two: the Uninstall icon for 2.0 appears to use the updated, darker blue icon, but the Play Artemis icon is still the old light blue one. Not sure what either of these could mean with regards to the bug.

PS: Apologies for the frown emoticon in the error report. I can't seem to get it to display as the colon and start parentheses that it actually is.
RamonSnir

Registered:
Posts: 6
Reply with quote  #2 
I too couldn't get Artemis 2.0 to run on my Fedora. Installed just fine.
Morthos

Registered:
Posts: 2
Reply with quote  #3 
I, too, had trouble creating a Wine bottle for Artemis 2.0, getting the same page fault. However, I've managed to install and launch it on both of my Macs using PlayOnMac.
beelzebub

Registered:
Posts: 3
Reply with quote  #4 
Hi all,

me four, right down to the short burst of opening music after the loading completes. Wineskin error report below, but the interesting thing is that 1.66 (demo) worked fine and 2.0 works fine using PlayonMac. Tobias, any details on your PlayonMac install? I don't have any experience with Wine, but we might be able to debug with a bit of common sense...

Beel

******

 
fixme3d:init_driver_info Unable to find a driver/device info for vendor_id=0x1002 device_id=0x71c5 for driver_model=2
fixme:win:EnumDisplayDevicesW ((null),0,0x32f33c,0x00000000), stub!
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
fixme3d:swapchain_init The application requested more than one back buffer, this is not properly supported.
Please configure the application to use double buffering (1 back buffer) if possible.
fixme:imm:ImmReleaseContext (0x2006a, 0x18e3c8): stub
fixme:coreaudio:get_channel_mask Unknown speaker configuration: 16
fixme:coreaudio:get_channel_mask Unknown speaker configuration: 16
fixme3d:state_zenable Z buffer disabled, but ARB_depth_clamp isn't supported.
fixme3d:init_driver_info Unable to find a driver/device info for vendor_id=0x1002 device_id=0x71c5 for driver_model=2
fixme:win:EnumDisplayDevicesW ((null),0,0x32f33c,0x00000000), stub!
fixme3d:swapchain_init The application requested more than one back buffer, this is not properly supported.
Please configure the application to use double buffering (1 back buffer) if possible.
fixme3d9irect3DShaderValidatorCreate9 stub
wine: Unhandled page fault on read access to 0x065f11fc at address 0x4ca780 (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x065f11fc in 32-bit code (0x004ca780).
Register dump:
 CS:0017 SS:001f DS:001f ES:001f FS:1007 GS:0037
 EIP:004ca780 ESP:0032f918 EBP:0032f920 EFLAGS:00010616(  R- -- DI   -A-P- )
 EAX:065f1200 EBX:02a4d970 ECX:0197c480 EDX:00000000
 ESI:065f11fc EDI:0a4e00cc
Stack dump:
0x0032f918:  02a4d948 02a4da80 00000000 00422333
0x0032f928:  03eeeed0 00000000 065f1200 52d314af
0x0032f938:  02a4d948 0032f9a4 02a4da50 02a4da80
0x0032f948:  0032f970 004eaf4b ffffffff 0041facd
0x0032f958:  52d314cb 00000000 0032f9a4 0032fb94
0x0032f968:  02a4d948 02a4d948 0032fb84 004eb39b
0200: sel=1007 base=7ffc0000 limit=00000fff 32-bit rw-
Backtrace:
=>0 0x004ca780 in artemis (+0xca780) (0x0032f920)
0x004ca780: repe movsl(%esi),%es%edi)
Modules:
ModuleAddressDebug infoName (33 modules)
PE  400000-  5fd000Export          artemis
PE  600000-  838000Deferred        d3dx9_24
PE10000000-10039000Deferred        ftd2xx
PE404b0000-404b4000Deferred        version
PE404e0000-404e4000Deferred        mpr
PE40710000-40714000Deferred        setupapi
PE40780000-40784000Deferred        advapi32
PE41b10000-41b3e000Deferred        user32
PE41c50000-41c54000Deferred        gdi32
PE41d70000-41d74000Deferred        rpcrt4
PE41f10000-41f14000Deferred        wininet
PE41f70000-41f74000Deferred        shlwapi
PE41ff0000-420fe000Deferred        shell32
PE421f0000-42210000Deferred        comctl32
PE422f0000-422f4000Deferred        ws2_32
PE42330000-42334000Deferred        msvcrt
PE423d0000-423d4000Deferred        dsound
PE42430000-4243b000Deferred        winmm
PE42480000-42488000Deferred        ole32
PE425c0000-425c4000Deferred        msacm32
PE42660000-42664000Deferred        winex11
PE428a0000-428a4000Deferred        uxtheme
PE428d0000-428d3000Deferred        usp10
PE42910000-42914000Deferred        imm32
PE42940000-42944000Deferred        d3d9
PE42980000-42984000Deferred        wined3d
PE42ac0000-42ac4000Deferred        opengl32
PE43760000-43764000Deferred        mmdevapi
PE43790000-43793000Deferred        winecoreaudio
PE44330000-44337000Deferred        oleaut32
PE46a50000-46a54000Deferred        iphlpapi
PE7b810000-7b9ab000Deferred        kernel32
PE7bc10000-7bc14000Deferred        ntdll
Threads:
process  tid      prio (all id:s are in hex)
00000008 (D) C:\Program Files\Artemis\Artemis.exe
00000026   15
00000024    0
00000009    0 <==
0000000e services.exe
0000001e    0
0000001d    0
00000018    0
00000016    0
00000014    0
00000010    0
0000000f    0
00000012 winedevice.exe
0000001c    0
00000019    0
00000017    0
00000013    0
0000001a plugplay.exe
00000020    0
0000001f    0
0000001b    0
00000021 explorer.exe
00000023    0
00000022    0
 

Wineskin wrapper version 2.5.10
Wineskin engine version WS9Wine1.7.0X
croxis

Registered:
Posts: 7
Reply with quote  #5 
Same with wine 1.7 on 64 bit arch.

Which blows my plans on hosting a party out the window. My media server hooked up to the tv only has linux. I suppose I could try running xp in a vm....
Tobias Cormano

Registered:
Posts: 7
Reply with quote  #6 
Beel,
As it turns out, I made a mistake when installing PlayOnMac the first time. Following the instructions found here to the letter fixed the problem. Probably when I reported that 2.0 wouldn't run, my computer was still using X11 instead of XQuartz, as I hadn't restarted as I was supposed to.
beelzebub

Registered:
Posts: 3
Reply with quote  #7 
Yeah, that'd do it. I was playing around last night and XQuartz is definitely required to get playonmac working. Croxis, it should be possible to get around this with a little bit of work, since PlayOnMac is just a Wine wrapper as far as I understand. If you can recreate the wrapper settings in normal Wine then you should be away.

I'm going to have a crack with Winebottler over the weekend, see if that gets better results. It'll be a lot easier for my group (all mac users) if I just have a package ready to roll.
beelzebub

Registered:
Posts: 3
Reply with quote  #8 
Winebottler won't even install Artemis. I've failed miserably to debug, to no effect...
jhkrischel

Registered:
Posts: 12
Reply with quote  #9 
Just confirming that the latest PlayOnMac works for me - although I'd love to do it with Wineskin Winery instead!
Grizzly

Registered:
Posts: 1
Reply with quote  #10 
Hi Guys,

I just thought that I'd add in my experience.  I have a Macbook and I've been using Crossover to run Artemis.

Artemis 2.0 did not work for me.  I received the same error as mentioned above.  A brief few notes of music and then the crash message.  I tried several different 'bottler' operating systems, XP, Vista, Win 7, but they all behaved the same.  I can still run 1.7 successfully.

Haven't tried PlayonMac yet.
TommiH

Avatar / Picture

Registered:
Posts: 43
Reply with quote  #11 
2.0 works great with PlayOnMac. You can even configure the audio to be played thru AirPlay. You can easilly start a server and 4 client instances on the same machine.

In action:


I just ordered a DMX controller and some lights, we'll see if it works with Wine, or do I have to setup a dedicated server for 2.0.
jgreene@greenemyst.com

Registered:
Posts: 141
Reply with quote  #12 
Please share your version data.. like wine Ver
__________________
Volg Clawtooth
Chief Engineer of Myst Brigade
Artemis: Greater Indianapolis
CaptHomko

Registered:
Posts: 1
Reply with quote  #13 
I have 2 Mac Minis. Artemis runs OK on one Mac with PlayOnMac and the other does not. I have a possible theory:

One is a newer model Intel processor i5 2.0 GHz with 4 gigs of memory and the other is an older model intel processor core duo 1.82 GHz. Both PlayOnMac installs were identical. On my older Mac when running Artemis I get a screen that has all alphabet characters (image attached). I am thinking maybe it is being caused by memory size? One Mac has 2 Gig and the other has 4 Gig?

Attached Images
jpeg artemis2playonmacerror.jpg (83.06 KB, 6 views)

TommiH

Avatar / Picture

Registered:
Posts: 43
Reply with quote  #14 
Quote:
Originally Posted by jgreene@greenemyst.com
Please share your version data.. like wine Ver


I'm not sure if you were talking to me, but the PlayOnMac is version 4.2.1 with Wine version 1.4. It downloaded the newest wrappers (I think they were called that) etc. when I installed PlayOnMac a few days ago.

jgreene@greenemyst.com

Registered:
Posts: 141
Reply with quote  #15 
Thanks! I'll add it to my research list for quantifying what's breaking..
__________________
Volg Clawtooth
Chief Engineer of Myst Brigade
Artemis: Greater Indianapolis
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.