Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Richard

Registered:
Posts: 127
Reply with quote  #1 
Hi,

I´m experiencing the most wierd issue with my mission script (see attached file): everything looks fine but the game crashes.

I´ve checked my script dozens of times but I couldn't find this fatal error so I decided to disable all events from the start and reenable them one by one.
  • Until event line 129 things seem to work fine (see debug event printscreen).
  • Until event line 192 the script works fine (note that  line 180 remain disabled because it will be deleted, not used anymore).
  • When events line 215 and 270 are enebled the game crashes.

Could it be some sort of Editor bug? I´m using :
  • fresh install Artemis 2.1.1 (The same error happens with Artemis 2.1.1 and 2.1.5)
  • no mods
  • Artemis Mission Editor 020101.5
  • Windows 8
Can anyone help me?

Thanks

ps.: the script is in portuguese so I think I need to explain it a little:
  • the player must go to A1 and scan (science press "1")
  • Then a new point will appear in the map ("SV1?") and the player must go there
  • When the player gets closer to "SV1?" it changes to "SV" and an enemy vessel appears ("KC01")
  • Then the player is close to the SV1 he can scan it (science press "1")

Debug events.PNG  








 
Attached Files
zip MISS_Tormenta_1.zip (7.55 KB, 3 views)

Fish Evans

Registered:
Posts: 361
Reply with quote  #2 
Hello Richard

First of all you are not using an up to date version of the Mission Editor, I would recommend grabbing an updated version

I have identified one problem in your script in the indicated area that would cause a crash.

Event name: MENSAGEM QUE KC01 COMEÇA A ATIVAR TRANSPORTES

contains a Text Message that has no From field defined.

Line in Error
<incoming_comms_text>Tecle "F" para contatar a nave Kralien KC01.</incoming_comms_text>


Correction:
<incoming_comms_text from="something">Tecle "F" para contatar a nave Kralien KC01.</incoming_comms_text>
Richard

Registered:
Posts: 127
Reply with quote  #3 
Hello Fish,

The error you pointed doesn't seem to be an issue. The statement works even if the fild incoming_comms_textfrom="" (or Null when using the editor). I replaced that field in other events and they worked perfectly.

But a misterious thing happened: I ran the script today and it worked! Maybe it was some kind of Kralien magic...

Actually the only thing i did different was to first open and save the script with the version 020101.5 of the Mission Editor. Is it the last version, right?

The problem is solved.

Thanks for you attention!


 
 
Fish Evans

Registered:
Posts: 361
Reply with quote  #4 
.13 is the latest version of the editor

Very strange that you are not crashing with out the from attribute filled in, it most certainly causes a crash in 2.1.5.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.