Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 2 of 3      Prev   1   2   3   Next
Commander John Koenig

Registered:
Posts: 7
Reply with quote  #16 

If this is still an issue, there is one thing I would recommend checking.

Some brands of firewalls need to have "bridges" created between the wireless and wired networks, and they may not be configured to communicate to each other.  In essence, the wired network and the wireless networks are isolated.  Most of the time, this works just fine as most home users only use the network to connect to the internet and not to other computers on the network.

I had a similar issue when I first set up my network and had to manually "bridge" the wired and wireless networks.  I have a Checkpoint brand firewall, but other brands may have this setting by default also.

It may not help (or may not be an issue now), but may be worth checking out.

Cheers!

-John

LawsonThompson

Registered:
Posts: 589
Reply with quote  #17 
In addition to bridging, also look for a feature called "Wireless Client Isolation". That feature (when enabled) keeps the wifi devices from seeing each other, even though they can see the Internet. It's great if you're hosting a public WiFi hotspot, but very annoying if you're trying to play a game.

Bridging and client isolation are generally features on firewalls and routers more expensive than your typical $50 Best Buy box, so unless you have a really good router don't expect to see these features enabled or even available.

__________________
----
Visit us at http://www.ltebridge.com
LoB

Registered:
Posts: 45
Reply with quote  #18 
You guys are answering on a solved question. See quote below.
Just thought I'd let you know, though all your answers may be helpful for others.


Quote:
Originally Posted by Jeffreybomb
Happy to say that we were able to get all five laptops connected to the desktop server without a problem. Everyone was using a wireless connection, including the desktop server.

http://instagram.com/p/guEoh5ukF9/

It was a blast! Looking forward to having everyone over again to play some more.
TFossor

Registered:
Posts: 4
Reply with quote  #19 
Just want to report: setting up my basement in anticipation of Super Bowl Artemis Weekend, using three Win XP PCs and an iPad, all with Artemis 2.0.
Two of them with wireless cards, and an iPad.  One WinXP without wireless card.

Everyone can connect with each other EXCEPT the WinXP PC that uses a wired network connection.

AND I'm seeing the same strange behavior when it times out as client: the clock starts at ZERO then immediately the "failed to connect" message appears.  This is true despite putting router into DMZ, turning off router firewalls, and turning off Windows firewalls.

Strange behavior. But reproducible here.

Looks like I will have to hunt down a PCI network adapter card. Sigh.  Hope I can track one down...
TFossor

Registered:
Posts: 4
Reply with quote  #20 
Okay, problem REALLY TRULY solved this time.

In these situations, one has to right click on the artemis icon and choose to PLAY AS ADMINISTRATOR on the wired computer(s).

Worked like a charm.

Hope this helps someone else.  But weird behavior, reproducible.
pupbrad

Avatar / Picture

Registered:
Posts: 889
Reply with quote  #21 
Great find! This will surely help others in the future!
__________________
Captain of the USN Basroil.
"I am a leaf on the wind. Watch how I soar." - Hoban Washburne
"Give me a ship to fly and I'll make it sit up and beg, roll over (but NEVER play dead), and even do the jitterbug if you so fancy." - Unknown
TFossor

Registered:
Posts: 4
Reply with quote  #22 
And also had problems with iPad connection in this mixed network of wired/unwired, with the server wireless Win8, but everyone else running WinXP (two wireless, on wired).

EVERYONE but iPad could connect until the router was set to port forward TDP 2010 to the server.

Only then was the iPad able to connect.
pupbrad

Avatar / Picture

Registered:
Posts: 889
Reply with quote  #23 
odd... that implies the iPad refused to go through the home network and went out to the internet then back into the home network before trying to connect...
__________________
Captain of the USN Basroil.
"I am a leaf on the wind. Watch how I soar." - Hoban Washburne
"Give me a ship to fly and I'll make it sit up and beg, roll over (but NEVER play dead), and even do the jitterbug if you so fancy." - Unknown
TFossor

Registered:
Posts: 4
Reply with quote  #24 
Yes, I know.

But just reporting what I found.

As soon as I forwarded those ports, no problem with iPad (though without port forwarding, the three XP PCs could connect to the Win8 server).
Timby

Registered:
Posts: 1
Reply with quote  #25 
On the Connect 0 error, we discovered at least on Winxp, that in the Windows Registry, under the Artemis Spaceship Bridge Simulator heading, there was a NULL entry(0) in front of my I.P. Address.  Once we removed the 0, the Connection no longer showed it giving the Message: Connect 0, Unable to connect.  Now it connect's fine.
  Hope this helps,
Talk U later..
  Timby
cheesington

Registered:
Posts: 1
Reply with quote  #26 
Thanks Timby, that worked for me too.  Going into the registry and removing the garbage characters from in front of the ip address worked, even when playing the game as administrator didn't. 

For others, it's found here in the registry:

Computer\HKEY_CURRENT_USER\Software\ArtemisSBS

FWIW, I'm using a netbook with windows 7 starter edition on it. 
Hnefatafl

Avatar / Picture

Registered:
Posts: 15
Reply with quote  #27 

THANK YOU!  This was driving us crazy, running three laptops and three towers, and one just wouldn't connect to the server.  We could run the server on that laptop and connect to it, but even a second instance of the program couldn't connect using "localhost".

Went into the registry, and sure enough found garbage characters preceding the IP.

Everything works!


__________________

Commander Hood, 9th Fleet Operations

Commanding Officer, TSN Yale: 9th Fleet Academy Training Vessel
Helmsman, TSN Vanguard

Gadgetskopf

Registered:
Posts: 1
Reply with quote  #28 
I understand this topic is old and several solutions have been supplied/confirmed, but I ran into this same issue, and ended up solving it before finding this thread, so I don't know if my solution in some way fixed the garbaged registry without using regedit, but wanted to share anyway in the interest of 'more info greater than less'.

I was setting up a bridge for my son's 14th bday party the night before (no pressure...) and it was the first time I had done so since the upgrade to 2.3 had been released (life trumps Artemis... who knew?)  I'm fairly certain I the last time I had run a bridge was under 1.7, to be honest, but my son read about the fighters craft available in 2.3 and had to have a go with them <grin>.

The server and all clients were connected via wireless (normally my server is connected via wire clients are a mix of wired/wireless, but I was setting up at a different location affording more room).

One client would connect and 5 would not.  I went through all permutations of disabling firewall/antivirus/etc.  What was totally perplexing was that outside of hardware differences, (video drivers mostly), 3 of the trouble clients were configured almost identically to the one client that successfully connected (quick builds using something called "Tiny 7" which is a 32bit Windows 7 install stripped of all unnecessary bloat).

At one point, even though all failing clients appeared to have the correct IP information, I picked one at random, cleared and re-typed the IP, and got a connection!  I realized at that point (this was after several hours of teeth-gnashing and hair-pulling) that after I had typed in the IP address, I had pressed the enter key instead of clicking the connect button.  This did not initiate the connection, of course, but when I did click connect, instead of the 'zero countdown', it jumped to 8, started counting down, and connected.

This seemed a bit odd to me, so on one of the other failing clients, instead of re-typing the IP, I simply clicked in the text entry box, pressed enter, and clicked connnect.  VOILA!  connection!  I quickly got all clients connected, dragooned the local board gaming group (that was conveniently handy and had been listening to my imprecations all night) into playing a quick test round, and everything performed flawlessly.

On the down side, it was almost 2AM.  On the up side, the board gaming group is now working out logistics to start a regular Artemis Gaming night!
ryleyra

Registered:
Posts: 2,915
Reply with quote  #29 
Interesting. I wonder if there may be a keyboard driver issue. Anyway, thanks for the info, it may help someone else.

Welcome to the Artemis 2.x series! [biggrin] I'm sure you've noticed by now, there are some significant upgrades. There are enemy bases, game modes in which you're the invader attacking Kralien space, and a whole bunch of new space monsters. Not to mention the Upgrades picked up from anomalies.

Fighters are definitely the Next Big Thing (TM) but I'm sure your group will be exploring the new features for a while to come. And it's nice to hear fighters have drawn an old player back in! [biggrin]
LoB

Registered:
Posts: 45
Reply with quote  #30 
Sorry for waking up an old thread, but I had another finding on this topic.
Last week-end we had a LAN party and stubled across the same problem. It really destroyed the fun a bit, because it took us hours to figure it out (sadly enough I had seen this thread here, but not page 2... [rolleyes])

We basically found a workaround: By entering the IP adress in the ini file (artemis.ini) in the parameter "forceAddress" we were able to make all clients connect.

We assumed that this problem is some kind of encoding and/or line ending problem, and your findings about garbage in the registry and differences when using Enter support this hypothethis. Should be easy to fix imho if the developer has a quick look into it.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.