Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 46 of 52     «   Prev   43   44   45   46   47   48   49   Next   »
Mike Substelny

Avatar / Picture

Administrator
Registered:
Posts: 2,261
Reply with quote  #676 
Quote:
Originally Posted by anwoke8204
Hey @markbell I might have found a bug in 2.6 scripts, not sure if it will be the same in 2.7.  or perhaps I could be an issue with our scripts, I am not sure, but Friendly ships are not accepting any commands from communications.


That's not a bug in the mod; it's a change in Artemis itself. A couple of years ago friendly ships spawned by a script no longer get the brainstack element follow_comms_orders. Your script needs to give that to every friendly ship if you want it to respond. It can be a pain in the butt if you are spawning friendly ships with random names.

__________________
"The Admiralty had demanded six ships; the economists offered four; and we finally compromised on eight."
- Winston Churchill
MarkBell

Avatar / Picture

Administrator
Registered:
Posts: 1,925
Reply with quote  #677 
OK!  2.7.3b mod released!  Most of the enemies have been added back in.  Notable absences right now are the variety of Klingon ships, currently reduced to B'Rel, K'Vort, Vor'Vha, and Negh'Var, although I'm planning to pad that back out.  (The Romulans may similarly be chopped down and then built back up soon.)  This is because those are the only ones I've finished so far, while the rest of the enemies are from the old mod.  It's 2.7.3b because I still need to add in a Hideki for the Cardassians to have a "small" tag ship (the Galor has been changed to a "medium" tag just to make sure existing scripts with properly loaded declaration terms won't miss), and work on getting all the other ships into the updated, shared texture format. Otherwise it seems stable, the player shuttle bug is fixed so feel free to shuttle around, I added the new fighter bay image, and I haven't managed to make it crash yet.  

Get it here, and kick the tires!  DOWNLOAD



__________________
Note - this is in no way intended to be an official position of Thom or Artemis, as I am not an official representative of the creator or game.
anwoke8204

Registered:
Posts: 205
Reply with quote  #678 
Perfect, thank you mark.  I am downloading it now.
anwoke8204

Registered:
Posts: 205
Reply with quote  #679 
Mark is there a difference between how the 2.6 vesseldata.xml file and the 2.7.x reads in Artemis.  We use Dales Artemis Mission Editor to create all of our missions, and we are unable to get it to read the vesseldata file for 2.7.x and import the vessels so we can use them in the mission editor.  however if we point the mission editor to the 2.6 vesseldata.xml file it loads the ships just fine.
MarkBell

Avatar / Picture

Administrator
Registered:
Posts: 1,925
Reply with quote  #680 
Hmm, that's interesting. Have you tried loading ships from ghee 2.7.2 or 2.7.3 stock vesselData? That might tell us if it's a version thing. 
__________________
Note - this is in no way intended to be an official position of Thom or Artemis, as I am not an official representative of the creator or game.
anwoke8204

Registered:
Posts: 205
Reply with quote  #681 
Mark, my twin took a look at the xml file in preperation for spikecon, and he found there was a duplicate ID in the vessel data file

the romulans and Arvonian are both Hull ID 3000

He changed that and it imported like it should have.
MarkBell

Avatar / Picture

Administrator
Registered:
Posts: 1,925
Reply with quote  #682 
Ah crap, I meant to delete those.  Just a sec and I'll update the download, but just deleting the Arvonian entries should do it. Unless I missed some Skaarans.... basically the only stock entries should be the biomechs.
__________________
Note - this is in no way intended to be an official position of Thom or Artemis, as I am not an official representative of the creator or game.
anwoke8204

Registered:
Posts: 205
Reply with quote  #683 
e says he grabbed the romulans xmldata file info and copied it into the 2.7.3 mod and it worked, so im thinking its an issue with the duplicate hull id's he found

MarkBell

Avatar / Picture

Administrator
Registered:
Posts: 1,925
Reply with quote  #684 
So I just checked, the 2.7.3b vesselData file has no Arvonians in it, and no conflicting hullID entries.  I'm not sure why it's conflicting in the mission editor - maybe you need to unload the stock data file before loading the mod file?  Are you using only the vesselData from the downloaded mod file?
__________________
Note - this is in no way intended to be an official position of Thom or Artemis, as I am not an official representative of the creator or game.
anwoke8204

Registered:
Posts: 205
Reply with quote  #685 
Quote:
Originally Posted by MarkBell
So I just checked, the 2.7.3b vesselData file has no Arvonians in it, and no conflicting hullID entries.  I'm not sure why it's conflicting in the mission editor - maybe you need to unload the stock data file before loading the mod file?  Are you using only the vesselData from the downloaded mod file?


is there any way we could contact you via skype (he is at working, so has access to skype), so I was thinking we could do a 3 way skype message chat), and he could explain better whats he found

MarkBell

Avatar / Picture

Administrator
Registered:
Posts: 1,925
Reply with quote  #686 
Unfortunately, no, I can't.  Plus, it sounds like an issue with the mission editor, which I don't know much about.  The romulans load and explode while playing the game itself.   There's got to be a way to unload extant entries in the mission editor to replace them with new ones.  
__________________
Note - this is in no way intended to be an official position of Thom or Artemis, as I am not an official representative of the creator or game.
dellborg82

Registered:
Posts: 3
Reply with quote  #687 
Hey Mark,

I started off using the vessel.xml file that we were given of the partial mod so I could get started on upgrading our mission scripts. When Kacie had told me about the mod being completed, and got everything for me as i'm currently at work, I started working on it during my breaks. (Like I am currently doing to reply) The mission script with the Mod in progress vessels.xml script would pull up the ships etc just fine. When I told the mission editor to use the new one realeased last night, we started getting the error hullID="[1500]" Vessel does not exist. So I pulled up both vessel files in Aptana Studio, and started comparing the two. I then started copying Race by Race from the new file (released last night) into the work in progress file. After each "copy" I would save it, and reload in mission editor. So far so good; until, I got to the Romulans. It took a while before I realized that in that file the Romulans and the Arvonian both had the same Hull ID numbers. So I deleted everything from Stock Artemis out of that file, and copied the Romulans over again... And it worked. I continued Coping Race by Race ships from the newly release Vessel.xml file into the work in progress mod file we were given earlier. After completing the copy of everything, All vessels, races, stations etc are in, and it's working. 

I'm still haven't figured out what's stopping the new file to pull up the vessel does not exist error, but I was able to replicate it again. I'll Delete the stock stuff out of it, like suggested above, and see what happens. 
MarkBell

Avatar / Picture

Administrator
Registered:
Posts: 1,925
Reply with quote  #688 
Hiya!  Glad you got it working!  I'm not sure why it's giving you such a problem with it, although duplicate hullID is guaranteed to give you heartburn.  The file loads and plays fine in regular play, so I'm not sure why the mission editor isn't loading it properly.  When you load it up, does you load a vesselData file explicitly? or is it working on a specific copy of it?  It could be that you needed to overwrite the vesselData file in the folder you were working in completely.
__________________
Note - this is in no way intended to be an official position of Thom or Artemis, as I am not an official representative of the creator or game.
ron77

Registered:
Posts: 150
Reply with quote  #689 
So, quick question:
Does the mod work now or do people still experience errors?
And if so, do you experience errors with the vessel data, or the mission editor when accessing the vessel data?
DizzyKungFu

Registered:
Posts: 92
Reply with quote  #690 
Minor note: the "Taking a Beating - Final" music file is still misnamed, so it does not overwrite the base game music file.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.