Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 2 of 2      Prev   1   2
Azhellarke

Avatar / Picture

Registered:
Posts: 8
Reply with quote  #16 

Ok WTF... I just solve my problem by right-clicking the icon in the task bar (Win10) and select Artemis.exe, then it opens a new window of Artemis with the correct scale. When I re-open the .exe with the shortcut from the desktop, Artemis opens normally.


I'm even more confused at this time...


__________________
[G9cXiYT] 
bau.movement

Avatar / Picture

Registered:
Posts: 96
Reply with quote  #17 
The fixes to this bug seem more bewildering than the bug itself. Glad you got around it.
__________________
Cincinnati Shipyards ~
There are no problems you can't fix with a large enough hammer.

--EYES ONLY: TSN Bergeron refit--
sbeu

Registered:
Posts: 2
Reply with quote  #18 
Same problem for me here.
I have a windows 2016 Server on Microsoft Azure, and same bug here. 
By RDP, there is no way to change the desktop resolution. I don't know what to do!!?
I have tried modifying varios parameters in the shortcut, but nothing works....
Any word from the devs?
Cap Naes

Registered:
Posts: 43
Reply with quote  #19 
Had this problem myself today. But only on one windows 10 machine- the other was fine. Did the change windows resolution, then changed back, and kapow, it was fixed. 

Totally bizarre bug.
Matsiyan

Avatar / Picture

Registered:
Posts: 70
Reply with quote  #20 
I have the issue on an Amazon EC2 Win2012 server and no way to change the resolution. Is there a workaround?
__________________
Captain Conrad Matsiyan - TSN Viper
4th Light Division, 2nd Space Fleet, Terran Stellar Navy
TSN RP Community  |  WTSN Fleet News Pulse Podcast  |  Stellar Navigation Console
natepiercy

Registered:
Posts: 2
Reply with quote  #21 
Bumping for hopes of support for RDP. It'd be really great to set a server on a remote machine at work that has a static IP and have my friends join that, rather than checking my IP every time and hosting from my dynamic connection at home.
insertwittynamehere

Registered:
Posts: 4
Reply with quote  #22 
Did anyone find a solution to this issue in an RDP session? Or are there other methods for setting up a remote server (Azure, Aws, etc)
LawsonThompson

Registered:
Posts: 625
Reply with quote  #23 
Here's an idea for "changing resolution" on RDP. You set the resolution in the Remote Desktop Connection app, before you connect: click Show Options.

Click Display tab, and turn down the resolution one "click".

Connect to your RDP session as usual, launch Artemis.exe.

Leave Artemis running in its "weird" state, then disconnect--do NOT log out--from RDP.

Restart Remote Desktop Connection, and set the resolution to a different value before connecting.

If Artemis.exe is still running, you did it right. Try closing and relaunching Artemis.exe now.

In theory, this may cause the RDP session to "report" a resolution change, which might then trigger whatever voodoo causes the resolution to be correctly detected.

OR... connect via RDP, launch TeamViewer on the server, disconnect RDP, and connect via TeamViewer instead. That should let you dynamically change resolution.

__________________
----
Visit us at http://www.ltebridge.com
insertwittynamehere

Registered:
Posts: 4
Reply with quote  #24 
Cheers for that. The team viewer idea worked for my azure vm.
CharlesRoth

Registered:
Posts: 3
Reply with quote  #25 
I still have the same problem (tiny, unusable resolution-setting window).  Trying to set up an Amazon AWS "LightSail" Windows Server 2016 box with Artemis.  (Gaming in the age of the corona virus.)  Tried versions 2.7.1 and 2.7.5 of Artemis, same problem.  Tried everything above, no luck.   Couldn't get TeamViewer to work, there's some suggestion that it may require 1GB... the smallest LightSail box only ("only"!) has 500MB RAM.

Any suggestions welcome.  I'd pay a bounty ($50) to see this fixed.
bau.movement

Avatar / Picture

Registered:
Posts: 96
Reply with quote  #26 
I don't know if you've tried this, but since we were all having the problem with the tiny start screen bug (I certainly spent a ton of time banging my head against it in prep for a scheduled game with 15 people coming, yikes) they've added an option to lock the starting resolution and window display type.

In 2.7.5 if you open the artemis.ini there is this language:

; -------------------------------------------------------------------------------------
; STARTUP RESOLUTION SETTINGS (the following settings let you bypass the initial screen dialog by specifying the screen mode and resolution here)
; -------------------------------------------------------------------------------------
;gameWindowWidth=850 (screen width in pixels; your screen may not be able to show all resolutions, especially in Full Screen mode)
;gameWindowHeight=800 (screen height in pixels; your screen may not be able to show all resolutions, especially in Full Screen mode)
;gameWindowMode=2 ("Full Screen" = 1, "Windowed" = 2, "Full Screen Windowed" = 3)

If you've already gone through all this, my apologies and sympathies.

Let us know how you are progressing/if you find a work around or solution.

Good hunting.


__________________
Cincinnati Shipyards ~
There are no problems you can't fix with a large enough hammer.

--EYES ONLY: TSN Bergeron refit--
Jukkorsis

Registered:
Posts: 1
Reply with quote  #27 
Hi,
I am also having this issue when I connect (via RDP) to a AWS windows server 2019.
I have trying the suggestion above, with no luck.
Does anyone have any other ideas.
Thanks in advance,
Jukkorsis
Coda-Coda

Registered:
Posts: 2
Reply with quote  #28 

Hi,

I've figured out a solution to the tiny screen problem that makes it possible to run Artemis on a remote server with port 2010 open.

@CharlesRoth - if you feel this is worthy of your bounty please get in touch [smile]

TL;DR - use Amazon Workspaces to avoid the tiny screen problem, following these public subnet instructions plus altering the security group to open port 2010.

Solution:

Amazon Workspaces

  • Create a Windows Server using Amazon Workspaces by clicking on the "Get started with Amazon Workspaces"

    • In Amazon Workspaces there is not the issue of Artemis appearing in a tiny screen when you connect using the Amazon Workspaces client.

  • Connect via the Workspaces client and install Artemis on it.

Open inbound traffic on port 2010

This is more complicated than with a normal AWS machine, but still quite doable.

  • Carfully follow the instructions to "Configure a VPC with Public Subnets" available from https://docs.aws.amazon.com/workspaces/latest/adminguide/amazon-workspaces-vpc.html#configure-vpc-public-subnets making note of the points below.

    • Follow the steps 1, 2, and 3 in "Configure a VPC with Public Subnets

      • During Step 2 - Add a Second Public Subnet

        • For step 6a (IPv4 CIDR Block). Use 10.0.1.0/24 or similar (the info here helped with this)

      • During Step 3 - Assign the Elastic IP Address

        • For step 7 (Select the network interface for your WorkSpace). Be sure to scroll across to see the "Primary private IPv4 IP" column and look for the IP address you copied in step 5.

  • Then: from the same page (that says "Create Network Interface" on the top left)

    • On the selected item that you just chose an Elastic IP address for

      • Click on the entry under security groups

      • Then click on the entry under "Security group ID"

      • Click Edit inbound rules

      • Click Add rule

        • Choose 2010 for "Port Range"

        • Choose "Anywhere" for Source Type

        • Optionally add a description e.g. "Artemis inbound rule"

        • Click "Save rules"

  • Then connect via the Workspaces client to your Amazon Workspaces VM

    • On your VM, google "what's my ip" or visit https://www.whatsmyip.org/ - share this IP address with your Artemis crewmates

    • Run Artemis as a server on your VM and then play as usual [smile]
      (Tip: if you want everyone to see the main screen at all times: instead of trying to screen-share the main screen, you can run two copies of Artemis on the clients with one dedicated to the main screen and one for their station(s) - this probably works better than screen-sharing the main screen.)

Enjoy!

RogerW37

Registered:
Posts: 74
Reply with quote  #29 
Quote:
In 2.7.5 if you open the artemis.ini there is this language:

; -------------------------------------------------------------------------------------
; STARTUP RESOLUTION SETTINGS (the following settings let you bypass the initial screen dialog by specifying the screen mode and resolution here)
; -------------------------------------------------------------------------------------
;gameWindowWidth=850 (screen width in pixels; your screen may not be able to show all resolutions, especially in Full Screen mode)
;gameWindowHeight=800 (screen height in pixels; your screen may not be able to show all resolutions, especially in Full Screen mode)
;gameWindowMode=2 ("Full Screen" = 1, "Windowed" = 2, "Full Screen Windowed" = 3)



I had high hopes this would fix the issue in RDC, but it did not unfortunately.

gameWindowMode 2 & 3 does bypass the initial screen and Artemis does load, however, Artemis itself is now in the postage stamp window.

gameWindowMode 1 produces an error message:

"DXUTERR_CREATINGDEVICE: This game could not start its graphics mode. Try upgrading your graphics software by using Microsoft's DirextX End-User Runtime Web Installer (use Google to find it)."  Followed by "Artimis.exe has stopped working"
Coda-Coda

Registered:
Posts: 2
Reply with quote  #30 

NOTE - elastic ip addresses are not free, and some other aws features used also may not be free.


Quote:
Originally Posted by Coda-Coda

Hi,

I've figured out a solution to the tiny screen problem that makes it possible to run Artemis on a remote server with port 2010 open.

@CharlesRoth - if you feel this is worthy of your bounty please get in touch [smile]

TL;DR - use Amazon Workspaces to avoid the tiny screen problem, following these public subnet instructions plus altering the security group to open port 2010.

Solution:

Amazon Workspaces

  • Create a Windows Server using Amazon Workspaces by clicking on the "Get started with Amazon Workspaces"

    • In Amazon Workspaces there is not the issue of Artemis appearing in a tiny screen when you connect using the Amazon Workspaces client.

  • Connect via the Workspaces client and install Artemis on it.

Open inbound traffic on port 2010

This is more complicated than with a normal AWS machine, but still quite doable.

  • Carfully follow the instructions to "Configure a VPC with Public Subnets" available from https://docs.aws.amazon.com/workspaces/latest/adminguide/amazon-workspaces-vpc.html#configure-vpc-public-subnets making note of the points below.

    • Follow the steps 1, 2, and 3 in "Configure a VPC with Public Subnets

      • During Step 2 - Add a Second Public Subnet

        • For step 6a (IPv4 CIDR Block). Use 10.0.1.0/24 or similar (the info here helped with this)

      • During Step 3 - Assign the Elastic IP Address

        • For step 7 (Select the network interface for your WorkSpace). Be sure to scroll across to see the "Primary private IPv4 IP" column and look for the IP address you copied in step 5.

  • Then: from the same page (that says "Create Network Interface" on the top left)

    • On the selected item that you just chose an Elastic IP address for

      • Click on the entry under security groups

      • Then click on the entry under "Security group ID"

      • Click Edit inbound rules

      • Click Add rule

        • Choose 2010 for "Port Range"

        • Choose "Anywhere" for Source Type

        • Optionally add a description e.g. "Artemis inbound rule"

        • Click "Save rules"

  • Then connect via the Workspaces client to your Amazon Workspaces VM

    • On your VM, google "what's my ip" or visit https://www.whatsmyip.org/ - share this IP address with your Artemis crewmates

    • Run Artemis as a server on your VM and then play as usual [smile]
      (Tip: if you want everyone to see the main screen at all times: instead of trying to screen-share the main screen, you can run two copies of Artemis on the clients with one dedicated to the main screen and one for their station(s) - this probably works better than screen-sharing the main screen.)

Enjoy!

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.