Sign up Calendar Latest Topics

  Author   Comment  

Avatar / Picture

Posts: 138
Reply with quote  #1 

On my Laptop I'm having a problem where when I start Artemis in Server mode it's showing the IP address of my Virtualbox host only network adapter and not the IP address bound to the Ethernet adapter on my PC.

Is there anything I can do to change what network it binds to?

I've tried adjusting the interface metrics to see if that would help (Giving my Wired Ethernet the lowest metric and my Virtualbox Virtual Ethernet interface the Highest) but it hasn't.

Windows 8.1


Avatar / Picture

Posts: 209
Reply with quote  #2 
Solving that problem is going be a matter of setting something in Virtualbox to pass the IP address of the real PC to the virtual host.  Any software running inside the Virtualbox will have no knowledge of anything outside the box (such as the PC's real IP address), unless Virtualbox itself passes the information through.

So, you might check the documentation for Virtualbox.  I found this link, which might help:

Specifically, you might check on the area dealing with port forwarding.

Author of:
Artemis Mod Loader.
The Big Red Button of Death!
ArtemisSBS-Protocol Sharp
DMX Commander
(contact me to become a contributer)
(and all are free)

Avatar / Picture

Posts: 31
Reply with quote  #3 
I've had the same problem with it wanting to use the Hamachi network adapter's IP address. I just exit out of Artemis and disable the Hamachi network adapter. Then the game shows the proper IP address until I reboot.

The Starship Bridge Simulation Network -

"News, discussions, and information to make your simulation experience more immersive!"


Posts: 24
Reply with quote  #4 
Is this not only a cosmetic problem?
Can you not conncet?
Previous Topic | Next Topic

Quick Navigation:

Easily create a Forum Website with Website Toolbox.