Register Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
anwoke8204

Registered:
Posts: 169
Reply with quote  #1 
ok, I am having issues with the mod and the following script.  the friendly ships aren't loading correct, sometimes we have to start the scenario twice before it the GM buttons show up, and some things aren't working at all.  can someone double check this and let me know what im doing wrong?  I am using the Mission Editor Software and Marks TNG mod with Artemis 2.4.

 
Attached Files
zip MISS_KeyTest.zip (5.09 KB, 2 views)

Fish Evans

Registered:
Posts: 334
Reply with quote  #2 
seems your trying to create players rather then creating neutrals when it comes to spawning friendlys

the GM button thing - the GM needs to be loaded in by the time the button create event happens, if the GM client is not in by this time it wont get the buttons one way aroudn this is to set up an initilize loop:

ie create a Initilize button that will spawn every 2-5 seconds until its hit, then have that button trigger the rest of the GM buttons - you dont want to recreate all the GM buttons repeadedly as it causes some selection issues when they are recreated.
anwoke8204

Registered:
Posts: 169
Reply with quote  #3 
Quote:
Originally Posted by Fish Evans
seems your trying to create players rather then creating neutrals when it comes to spawning friendlys

the GM button thing - the GM needs to be loaded in by the time the button create event happens, if the GM client is not in by this time it wont get the buttons one way aroudn this is to set up an initilize loop:

ie create a Initilize button that will spawn every 2-5 seconds until its hit, then have that button trigger the rest of the GM buttons - you dont want to recreate all the GM buttons repeadedly as it causes some selection issues when they are recreated.



What is the easiest way to create the initialize button?
Previous Topic | Next Topic
Print
Reply

Quick Navigation: