Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 2 of 2      Prev   1   2
Happybubba

Registered:
Posts: 2
Reply with quote  #16 

I am not getting this to work. I installed PlayonMac and then Quartz. I then downloaded the 2.7 version from Artemis website and choose to install 32-bit version inside PlayonMac.  Any tips would be greatly appreciated!! 

When clicking the Artemis icon inside playonMac I am getting the error (loosely translated from swedish): 

"Artemis.exe encountered a serious error and had to be terminated. [...] This was caused by errors in the program or a [lack] in Wine. 



Newcommerin

Avatar / Picture

Registered:
Posts: 190
Reply with quote  #17 
Since I don't have a mac this post may be stupid, but I try it anyway. [wink]

Did you load the full version of Artemis or just the updater, that required an already installed Artemis 2.0? Only the updater won't work on any machine.


__________________
Sorry, English is not my native language, I am German.
(* I wish I would live in America, I wish I would... *)
Any mistakes you can find, you can keep and with the spelling mistakes you can cook you an alphabet soup.

My Artemis Homepage: https://star-ship-academy.jimdo.com/
NoseyNick

Avatar / Picture

Registered:
Posts: 112
Reply with quote  #18 
Catalina (including WINE on Catalina) lost the ability to run 32-bit apps, which includes Artemis.exe. Me not happy.   [mad]
fernandogil

Registered:
Posts: 1
Reply with quote  #19 
I managed to get Artemis 2.7.5 (Steam version) working on macOS Mojave 10.14.6. I first tested the demo version available in the website, but it didn't work.

Currently, I am running Artemis on Wine 5.0 installed through Homebrew.

A step-by-step would be:

1. Install Homebrew from https://brew.sh/
2. Install XQuartz

brew cask install xquartz

3. Install Wine

brew cask install wine-stable

4. Install Steam, the Windows version from https://steamcommunity.com/
5. Open Steam and buy/download Artemis
6. Have fun

I also saw that macOS Catalina doesn't support 32 bits applications and Wine is not totally compatible yet, so I would not upgrade to it yet.

Hope it helps!
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.