Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
that one dude

Registered:
Posts: 1
Reply with quote  #1 
How do I run Artemis on Mac using WINE or something. I don't want to use bootcamp, so WINE is preferred.

Thanks!
William

Registered:
Posts: 115
Reply with quote  #2 
I used wine bottler with Artemis 2.1.1 intstaller. It worked. You must install quartz X11 from apple first. It is needed for the graphics.
User McUser

Registered:
Posts: 118
Reply with quote  #3 
I've used "Play On Mac" which is just a video game oriented WINE bottler.

http://artemiswiki.pbworks.com/w/page/58169282/Artemis%20on%20Mac%20the%20easy%20way%20-%20with%20PlayOnMac
https://www.playonmac.com/en/
NickAtNight

Registered:
Posts: 2
Reply with quote  #4 
I just used Artemis with Parallels Desktop 11 for Mac.
 - Windows operating system was Windows 10.

It worked fine.

I prefer Parallels because both the OS X and the Windows software can be operated at the same time.
mattssheep4

Avatar / Picture

Registered:
Posts: 42
Reply with quote  #5 
Quote:
Originally Posted by User McUser
I've used "Play On Mac" which is just a video game oriented WINE bottler.

http://artemiswiki.pbworks.com/w/page/58169282/Artemis%20on%20Mac%20the%20easy%20way%20-%20with%20PlayOnMac
https://www.playonmac.com/en/

I made a google form that serves as a checklist for this! Hopefully it will help people from getting confused with all the "Next"s and getting out of order so easily.

https://docs.google.com/forms/d/1rE1psJGY5fTz-sCB9FzVEou4_tagozU_2VQODVTh2ro/viewform
__________________
Subkommanant Matthew Vaj, XO ISN Invictus, 4th Hunter Group, 2nd Space Flotilla | TSN RP Community - Listen to our Fleet News Service!

Intelligence Officer of the Cygnus Campaign

pavlvs

Registered:
Posts: 10
Reply with quote  #6 
I used PlayOnMac on a 15" Retina MBP with dual graphics cards.
The framerate was awful until I set the following in the "Display" settings tab after clicking "Configure":

GLSL Support: disabled
Offscreen rendering mode: fbo


LawsonThompson

Registered:
Posts: 571
Reply with quote  #7 
Quote:
Originally Posted by pavlvs
I used PlayOnMac on a 15" Retina MBP with dual graphics cards.
The framerate was awful until I set the following in the "Display" settings tab after clicking "Configure":

GLSL Support: disabled
Offscreen rendering mode: fbo




This same fix permits Artemis 2.7 (Feb 2018) to run instead of crashing at startup on PlayOnMac.

__________________
----
Visit us at http://www.ltebridge.com
lebowits

Registered:
Posts: 8
Reply with quote  #8 
@Lawton - What version of MacOS are you running.  I'm running Mojave (10.14) under which I've installed PlayOnMac.  Followed the process to install Artemis.  It launches the resolution selection dialog but crashes immediately when I attempt to start the game.  I found your post about changing the display settings and set those as well.  Still no joy.  Crashes every time.

If anyone has any suggestions, I'd be grateful.  
e4mafia

Registered:
Posts: 177
Reply with quote  #9 
What version of PlayonMac are you using? I had some issues with the latest build and rolled back to my previously functioning 4.3.2 - Haven't tried recently doing any newer builds. I'm on Mojave as well. Generally very stable, and used it many times. For my most recent mission, I ran it under a Parallels VM, and it was flawless. Do your display settings match these?
This is what is currently working for me.

Screen Shot 2019-06-18 at 4.39.22 PM.png 

lebowits

Registered:
Posts: 8
Reply with quote  #10 
I'm running PlayOnMac 4.3.4.  I've started looking for 4.3.2 but haven't had any luck yet.
lebowits

Registered:
Posts: 8
Reply with quote  #11 
I neglected to mention that I have the same display settings you show in your screen cap.  Thanks for that!
LawsonThompson

Registered:
Posts: 571
Reply with quote  #12 
Quote:
Originally Posted by lebowits
@Lawton - What version of MacOS are you running.  I'm running Mojave (10.14) under which I've installed PlayOnMac.  Followed the process to install Artemis.  It launches the resolution selection dialog but crashes immediately when I attempt to start the game.  I found your post about changing the display settings and set those as well.  Still no joy.  Crashes every time.

If anyone has any suggestions, I'd be grateful.  


I'm running High Sierra on a quite old 2011 Mac. I seem to recall having this same problem. 

I think I selected a very small resolution and windowed mode, just to get it working first, and then could select the higher resolution and borderless mode after that.

__________________
----
Visit us at http://www.ltebridge.com
lebowits

Registered:
Posts: 8
Reply with quote  #13 
I finally found a solution to my problem.  I had been trying to run the game both under VMWare Fusion 11 and using PlayOnMac (Wine).  Both were failing miserably.  The VM had Windows 7.  I had also created a new VM with a fresh OS install just to be sure there wasn't anything lurking in the background that was causing a problem.  This still failed.  I decided to spend a few bucks and get a license (and DVD) for Windows 10 (Home).  I created a new VM, installed the OS and then installed Artemis.  The game runs just fine in this environment.  I'm beginning to wonder if something in the way the game is compiled may have made the executable incompatible with the older OS.  I could be wrong, but this new OS did the trick.
e4mafia

Registered:
Posts: 177
Reply with quote  #14 
Wow thats really weird.
So you were doing playonmac natively inside of OS X(Sierra, high Sierra, Mojave, etc.?) - no go
Windows 7 VM in fusion - no go
Windows 10 VM in fusion - OK

?
lebowits

Registered:
Posts: 8
Reply with quote  #15 
@e4mafia - You've got that right.

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.