Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
anwoke8204

Registered:
Posts: 184
Reply with quote  #1 
Can someone help me debug these scripts?  the first one MISS_Conspiracy works fine, but all of the others either crash when we select a ship or randomly during a 1 hour session.  we used MISS_Conspiracy as the base for all of the other scripts.  This scripts are designed to run on Artemis 2.4 with Marks TNG mod.  I can't seem to figure out why all of the other scripts are causing it to crash.  Everything looks fine to me.  We used the Conspiracy as the base and then just added an event or two on each one.

 
Attached Files
zip Saltcon Missions 2017.zip (72.02 KB, 4 views)

ryleyra

Registered:
Posts: 2,846
Reply with quote  #2 
I'll look into it, but be warned, there is no real way to test if the source of the crashes is the script or the mod, unless you re-write the mission to run with stock Artemis. If the problem is the mod, we can't really help you. Your best bet in that case is to wait for the TNG mod to be updated to 2.6 and report any crashes to Mark.
anwoke8204

Registered:
Posts: 184
Reply with quote  #3 
Has there been any luck with this?  
anwoke8204

Registered:
Posts: 184
Reply with quote  #4 
ok, so ive gone back through the scripts and I can't seem to figure out what is causing all other scripts other then conspiracy to crash randomly.  I have tried them on several different systems and servers to rule out hardware, so it has to be an issue with the scripts somewhere.  I don't see anything in the logs for it either, so I am not sure why I am having the issues.  I have tried restarting the server after every game and still crashes.  the Artemis Mission editor isn't able to detect any issues with the scripts, so I am at a loss.  Can someone take a look and see if they see anything and point me in the right direction?
LawsonThompson

Registered:
Posts: 505
Reply with quote  #5 
One thing's for sure: if you don't have the mod installed, any reference to missing vesseldata items will crash! Found that out the hard way while experimenting...

Do the crashes happen immediately after start? or mid-mission?


__________________
----
Visit us at http://www.ltebridge.com
anwoke8204

Registered:
Posts: 184
Reply with quote  #6 
We do have the mod install.  we are running Artemis 2.6 with the 2.6 version of the mod.  the crashes happen randomly.  We reboot the game server every hour after each game session, which does help but we still have random crashes.  I am not sure why the other scripts other then conspiracy keep crashing.  like I said earlier, we used the conspiracy script for the base of all of the scripts and just changed the layout a bit as far as where things spawn in.
Mike Substelny

Avatar / Picture

Administrator
Registered:
Posts: 2,049
Reply with quote  #7 
I assume you don't see any error message.

Which machines crash? Server? Helm? Weapons? Engineering? Science? Comms?

Do you have the mod installed exactly the same on all of the machines?

The randomness makes me think the crash is triggered by an AI action: launching a drone, spawning Piranhas, etc.. If some file is not present, or if something happens outside the game map, a crash may result.

__________________
"The Admiralty had demanded six ships; the economists offered four; and we finally compromised on eight."
- Winston Churchill
anwoke8204

Registered:
Posts: 184
Reply with quote  #8 
Correct, I don't see any error messages.  I checked and there weren't any messages.  our server is the main one that crashes, but we have had helm and communications crash as well.  We have the mod installed exactly the same on all of them, as we get one system up to date and then clone it out to all of the other systems, so its always the same on all of the systems.  I will have to watch and see if its centered around an AI action.   
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.