Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
chaos_forge

Registered:
Posts: 8
Reply with quote  #1 

Hi y'all, I'm running Artemis 2.7.1 on a Lenovo Y70 laptop running Windows 8.1.

I want to set some of the controls to something more intuitive for the typical gamer, since by default some of the hotkeys for certain actions require taking a hand off the mouse or WASD, which feels awkward. Specifically, I tried to set the z-axis up and down controls for helm to LShift and LCtrl, so I replaced the default lines in controls.ini with:

BUTTON_CLIMB = UI_INPUT_SHIFT
BUTTON_DIVE = UI_INPUT_LCONTROL

Shift to climb is working just fine, but when I press the control key nothing happens. Can anyone help me? Has anyone experienced similar problems?

Oh and I also wanted to set the fighter fire button to the right mouse button, but it's not clear from the comments in the file what label that would correspond to. Setting it to UI_INPUT_RBUTTON didn't seem to do anything.

DupeOfURL

Registered:
Posts: 251
Reply with quote  #2 
No help on the Control key {for Helm to go up and down} issue, but I've set fighter keyboard controls to use WASD, space to fire beam, Enter to launch torpedoes, and

FIGHTER_BOOST              =           UI_INPUT_KEY_M
FIGHTER_BRAKE              =           UI_INPUT_KEY_N

    {using the mnemonic M to Move and N to Not Move....}  in the Controls.INI file in the Artemis directory. 




__________________
on TeamSpeak as GreyBeard {the Grim}  ;-)
Chief Engineer of the Fulminata, one of the Pirates Of BeechWood! 
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.