Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 9 of 9     «   Prev   6   7   8   9
nschlein

Registered:
Posts: 57
Reply with quote  #121 
Hi Dave,
Finally had a chance to get back in and try to write a mission again.  Managed to encounter the issue.  It was with the TURN TO CURSOR command.

Create a ship.
Go to the Space map for editing
Select the ship.
Use the right button context menu to "turn to cursor."

Generates this message:
 
Screenshot 2020-09-14 024352.png 

Dave Thaler

Registered:
Posts: 506
Reply with quote  #122 
Quote:
Originally Posted by nschlein
Managed to encounter the issue.  It was with the TURN TO CURSOR command.


Thanks for the great bug report.  The bug is now fixed in the github sources, so will be included in the next version.
xscape

Registered:
Posts: 10
Reply with quote  #123 
Mission_editor_error.png

I am also seeing the following error when I attempt to either edit or add items to the space map, but I always get the big RED X on the space map no content. However as long as I do not enter the space map everything is ok.  

Dave Thaler

Registered:
Posts: 506
Reply with quote  #124 
Artemis Mission Editor v2.7.22 is now released.  Changes include:
  • Fixed exceptions in space map
I believe these should all be fixed now. Let me know if you still find any problems.

Edit: corrected version number in above
nschlein

Registered:
Posts: 57
Reply with quote  #125 
I also noticed yesterday that while generic meshes can be created on the space map (and edited at that time), they do not appear on the map subsequently.
xscape

Registered:
Posts: 10
Reply with quote  #126 
Hi Thanks for the quick turn around, however I don't think it resolved the issue. I am still getting the same error when I enter the Space Map

 
editor_error2.png 

Dave Thaler

Registered:
Posts: 506
Reply with quote  #127 
Ok, I was able to reproduce the issue xscape reported and v2.7.23 is now released.  This should fix that issue.  I was unable to repro any issues with generic meshes.
xscape

Registered:
Posts: 10
Reply with quote  #128 
Hi Dave,

Thank you so much, yes I just downloaded it and it is fixed.

I was in the middle of getting all of my system info and failures to send to you . 

Thank you again for the quick response and looking into it.

Cheers 
nschlein

Registered:
Posts: 57
Reply with quote  #129 
I’ll get back to the generic mesh matter it as soon as I can. It may have been fixed at the same time as something else.
What happened as far as I saw is this:

1. Created a generic mesh, and then went to “edit objects on space map”...and it wasn’t visible. (Wouldn’t even let me go to the space map to edit unless something else was created in the same event block.)

2. Created generic mesh on space map, edited it, all good...went to main editor, object is there...went back to space map and it’s not visible. :-(
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.