Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 2 of 2      Prev   1   2
mightytater

Registered:
Posts: 1
Reply with quote  #16 
I've got it to run nicely on Fedora using PlayOnLinux, and it's awesome... Is anyone using it as their server though?  Does anyone have suggestions on network config for that, since PlayOnLinux uses a bridged interface?

Thanks!
thorvindr

Registered:
Posts: 4
Reply with quote  #17 
Got 2.1.1 working on Ubuntu 14.04 (Trusty), using PlayOnLinux with Wine 1.7.6 (not sure if x64).
Commodore Erickson

Avatar / Picture

Registered:
Posts: 154
Reply with quote  #18 
I was able to get it to work in Ubuntu 14.04 using Wine, did not need play on linux.

I have also been able to run it in Edumbuntu Server 14.04 with Wine. This is currently my Artemis Server.

The memory leak issue is as always an issue in windows and linux.
lightningz71

Registered:
Posts: 1
Reply with quote  #19 

Success Report:

Version 2.1 Demo

Machine Type: Dell Optiplex 780
Pentium Dual Core Processor E5800
4 GB DDR-3 SDRAM
Built In Intel HD Graphics (Intel 4 series integrated graphics controller)

Linux Mint 17 64 bit

Installed with PlaysOnLinux under Wine 1.7.6 (64 bit windows)
Server works without any problems.  Client has occasional odd video artefacts, but is playable.  Speed is acceptable.


What I'm going to try next:  Installing the DEMO on a VSphere hosted virtual Linux machine and connecting from a client on a LInux client on the same LAN and attempt to play.

jgreene@greenemyst.com

Registered:
Posts: 141
Reply with quote  #20 
Somewhere around here  is my kickstart I built for this. using Fedora Core 19,  Wine 1.7.7. runs server and clients beautifully. Have run the configuration at multiple conventions now.
Even supports Wacom Digitizer Touchscreens fairly consistently.

__________________
Volg Clawtooth
Chief Engineer of Myst Brigade
Artemis: Greater Indianapolis
bennytheben

Registered:
Posts: 3
Reply with quote  #21 
Hi,

I've read several threads on here and on WineHQ but I can't seem to get Artemis to work with linux. Could someone give comprehensive details on their configuration? Do I need to install any libraries in the virtual drive on PlayOnLinux before running the installer?

Am I doing something wrong?
  1. I'm running Xubuntu 15.10 64-bit with Nvidia drivers installed.
  2. Launch PlayOnLinux
  3. Create fresh virtual drive (I've tried this process with 32-bit and 64-bit Wine versions of 1.5.19, 1.6.2, 1.7.7, and 1.7.55 - some of these were installed by default, and some of these I selected because they were reported to work on various threads).
  4. Install Artemis_Upgrade_v2_1_1.exe (I need 2.1 so the Android version can connect to it).
  5. Attempt to run Artemis.exe
  6. I see the resolution-picker window appear, but it's blank and immediately crashes.

The PlayOnLinux log says:
[11/21/15 16:31:14] - Running wine- Artemis.exe (Working directory : /home/ben/.PlayOnLinux/wineprefix/Artemis/drive_c/Program Files (x86)/Artemis)
fixme:win:EnumDisplayDevicesW ((null),0,0x32f6a4,0x00000000), stub!
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
fixme[biggrin]3d:swapchain_init The application requested more than one back buffer, this is not properly supported.
Please configure the application to use double buffering (1 back buffer) if possible.
fixme:imm:ImmReleaseContext (0x400c0, 0x17e710): stub
fixme:winediag:AUDDRV_GetAudioEndpoint Winepulse is not officially supported by the wine project
fixme:winediag:AUDDRV_GetAudioEndpoint For sound related feedback and support, please visit http://ubuntuforums.org/showthread.php?t=1960599
wine: Unhandled page fault on read access to 0x00000000 at address 0x40439e (thread 0031), starting debugger...
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x0040439e).
etc. etc. etc.

I'd really appreciate it if someone could give me some tips.

Thanks

 
Attached Files
txt playonlinux_log.txt (7.95 KB, 1 views)

bennytheben

Registered:
Posts: 3
Reply with quote  #22 
Sorry I was doing something stupid. I forgot to install 2.0 before running the update exes. Woops!

Maybe next time you release an update it would be good to inform idiot users which version of the game is already installed (if any) to stop this happening to someone else?
Luissen

Avatar / Picture

Registered:
Posts: 10
Reply with quote  #23 
I am running Artemis in WinE 1.7.6 on Fedora 22 x86-64

is anyone able to run more than one instance at a time without breaks in emulation? When I have 2 artemis windows running, only the focused one updates, leading to either the client disconnecting from the server due to timeout or the server complaining that there are no clients connected.

if I have both in client config, for multiple stations, one of the clients will fail to update if the server is on another machine
bennytheben

Registered:
Posts: 3
Reply with quote  #24 
I've had two instances running through Wine 1.6.2 in PlayOnLinux and I can play the game with either in the foreground and haven't experienced any issues. (one instance acting as server and one as a client)
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.