Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
grungydan

Registered:
Posts: 7
Reply with quote  #1 
I let the installer configure the firewall, then I made some manual rules to the firewall to make sure. Also opened TCP 2010 as suggested in another thread. 

This exact tablet and install has been used to connect to and play on a friend's server running 2.1.x in the past. 

Setup is a Windows 8.1 machine wired to router. Tablet is on the wireless network of said router and all other functions are normal. 

Start game on PC, start server. Start game on tablet, start client. Put in IP address and press connect, fails to connect. 

Any ideas or suggestions? 



Tec

Registered:
Posts: 24
Reply with quote  #2 
Is the Nexus online on UMTS?
Handy sometimes prefer UMTS for WIFI.
So please set UMTS off and check the WIFI IP of the Nexus.

grungydan

Registered:
Posts: 7
Reply with quote  #3 
Nope, the tablet is wifi only.
Tec

Registered:
Posts: 24
Reply with quote  #4 
And the IP is a good one? like 192.168.x.x and not 169.254.x.x ?

( For clearing the first address is a DHCP assign t address in a class C net, typical for home networks. The second one is a self assign t address if DHCP not correct work ) 
grungydan

Registered:
Posts: 7
Reply with quote  #5 
IP for server is 192.168.59.1. 

IP of the tablet is 192.168.2.6 so yup, good there as well.


Tec

Registered:
Posts: 24
Reply with quote  #6 
your mask is 255.255.0.0 ?
Dave Thaler

Registered:
Posts: 452
Reply with quote  #7 
Quote:
Originally Posted by grungydan
I let the installer configure the firewall, then I made some manual rules to the firewall to make sure. Also opened TCP 2010 as suggested in another thread. 

This exact tablet and install has been used to connect to and play on a friend's server running 2.1.x in the past. 

Setup is a Windows 8.1 machine wired to router. Tablet is on the wireless network of said router and all other functions are normal. 

Start game on PC, start server. Start game on tablet, start client. Put in IP address and press connect, fails to connect. 

Any ideas or suggestions?


Some things to check
1) Verify it's actually listening on 2010 (the networkPort can be configured in artemis.ini so if you changed it to something other than 2010 that would be a problem).  One way to verify is to run "netstat -nao | findstr 2010" and verify you see a line like this:
  TCP    0.0.0.0:2010           0.0.0.0:0              LISTENING       1304
where instead of 1304 you should see whatever the PID (process ID) is of your Artemis server instance.

2) Check which firewall profile is active.  One way to do this is from the Control Panel, just searching for "Windows Firewall" will take you there.   It should tell you that either "Guest or public networks" or "Private networks" or "Domain networks" are connected.  Usually the right one for playing artemis is "Private" (although technically it just has to be consistent with the #3 below).  A common problem would be where it's open in the firewall for one profile, and a different one is active.

3) Check which profiles are allowed for Artemis.  Do this through "Allow an app or feature through Windows Firewall" and look for the entry for "artemis".  Verify that the checkbox is checked for whatever firewall profile is active in step 2.

If the relevant checkbox isn't checked, you can either change the checkbox to be checked (usually the right thing if Private isn't checked), or you can change the active profile on your network adapter (usually the right thing if the active one is Public).  One simple way to do the latter is from the "HomeGroup" part of the control panel, which works even if you're not using homegroup.
grungydan

Registered:
Posts: 7
Reply with quote  #8 
Subnet mask is 255.255.255.0

netstat returns TCP  0.0.0.0:2010   0.0.0.0:0   LISTENING   368

Firewall settings double checked and verified.
Tec

Registered:
Posts: 24
Reply with quote  #9 
I think you should change the mask to 255.255.0.0.
Dave Thaler

Registered:
Posts: 452
Reply with quote  #10 
Whether you should change the mask or not depends on the topology.  All devices on the same subnet should have the same prefix (including prefix length or mask).  Here if the mask is 255.255.255.0 it indicates they're not on the same subnet.   That might or might not be right.   If they're both supposed to be on the same link, then the mask should be 255.255.0.0 on both machines as well as the router.   If they're on different links, the mask might be correct as is, but there may be some other connectivity problem between the two links.   We'd need to know more about the network topology to be sure, since wireless routers support both modes (wired and wireless on same subnet or on different subnets).   You can try pinging each IP address from the other one to see if you get responses (if you do, then Artemis ought to work since you verified the firewall settings).   If that doesn't work, you can try a traceroute ("tracert -d 192.168.59.1" from the tablet) and see what that gives you.  Your config would be correct if it showed you (say) 2 hops, both giving responses.   Chances are, one of the above things won't work since Artemis isn't connecting, and seeing what works and what doesn't will help narrow down the problem.
Tec

Registered:
Posts: 24
Reply with quote  #11 
Thanks for the full explaining^^
grungydan

Registered:
Posts: 7
Reply with quote  #12 
Info from Nexux 7:


Android IP Configuration
dummy0
DisplayName: dummy0
MTU: 1500
MAC: 6E-08-AA-5B-38-EA
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: false
[dummy0][2]
lo
IPv6 Host Name: localhost
IPv6 Address: ::1%1
IPv4 Host Name: localhost
IPv4 Address: 127.0.0.1
IPv4 Netmask: 255.0.0.0
DisplayName: lo
MTU: 16436
Loopback: true
Point To Point: false
Up: true
Virtual: false
Support Multicast: false
[lo][1][localhost/::1%1%1][localhost/127.0.0.1]
p2p0
DisplayName: p2p0
MTU: 1500
MAC: AE-22-0B-9B-B3-B8
Loopback: false
Point To Point: false
Up: true
Virtual: false
Support Multicast: true
[p2p0][23]
sit0
DisplayName: sit0
MTU: 1480
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: false
[sit0][21]
wlan0
IPv6 Host Name: fe80::ae22:bff:fe9b:b3b8%wlan0
IPv6 Address: fe80::ae22:bff:fe9b:b3b8%wlan0
IPv4 Host Name: 192.168.2.28
IPv4 Address: 192.168.2.28
IPv4 Netmask: 255.255.255.0
DisplayName: wlan0
MTU: 1500
MAC: AC-22-0B-9B-B3-B8
Loopback: false
Point To Point: false
Up: true
Virtual: false
Support Multicast: true
[wlan0][22][fe80::ae22:bff:fe9b:b3b8%wlan0/fe80::ae22:bff:fe9b:b3b8%wlan0%22][192.168.2.28/192.168.2.28]
rmnet_smux0
DisplayName: rmnet_smux0
MTU: 2000
MAC: 0E-7B-C0-E3-15-A9
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet_smux0][20]
rev_rmnet1
DisplayName: rev_rmnet1
MTU: 2000
MAC: D2-94-68-0F-D5-E9
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet1][12]
rev_rmnet0
DisplayName: rev_rmnet0
MTU: 2000
MAC: DE-0C-80-FF-7B-C8
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet0][11]
rev_rmnet8
DisplayName: rev_rmnet8
MTU: 2000
MAC: E6-75-FF-58-64-F9
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet8][19]
rev_rmnet7
DisplayName: rev_rmnet7
MTU: 2000
MAC: 5E-3C-B6-D1-A4-E5
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet7][18]
rev_rmnet5
DisplayName: rev_rmnet5
MTU: 2000
MAC: B2-68-93-7D-0E-C2
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet5][16]
rev_rmnet6
DisplayName: rev_rmnet6
MTU: 2000
MAC: A6-B2-B9-94-02-0D
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet6][17]
rev_rmnet4
DisplayName: rev_rmnet4
MTU: 2000
MAC: F2-99-5B-3D-AA-67
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet4][15]
rev_rmnet2
DisplayName: rev_rmnet2
MTU: 2000
MAC: F2-37-9A-B4-EB-6F
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet2][13]
rev_rmnet3
DisplayName: rev_rmnet3
MTU: 2000
MAC: D6-3A-14-09-14-45
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rev_rmnet3][14]
rmnet1
DisplayName: rmnet1
MTU: 2000
MAC: BA-C2-01-12-CB-FA
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet1][4]
rmnet0
DisplayName: rmnet0
MTU: 2000
MAC: EE-6D-0C-45-31-FA
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet0][3]
rmnet7
DisplayName: rmnet7
MTU: 2000
MAC: 4E-0A-07-55-F4-AD
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet7][10]
rmnet5
DisplayName: rmnet5
MTU: 2000
MAC: 22-E9-BA-E0-7C-63
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet5][8]
rmnet6
DisplayName: rmnet6
MTU: 2000
MAC: AA-71-BE-86-18-28
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet6][9]
rmnet4
DisplayName: rmnet4
MTU: 2000
MAC: BA-C9-63-22-7F-CB
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet4][7]
rmnet2
DisplayName: rmnet2
MTU: 2000
MAC: 26-1B-F4-3A-9A-32
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet2][5]
rmnet3
DisplayName: rmnet3
MTU: 2000
MAC: 4A-D1-D0-DA-49-E0
Loopback: false
Point To Point: false
Up: false
Virtual: false
Support Multicast: true
[rmnet3][6]
WiFi Status
BSSID: 08:86:3b:ba:9e:b5
MAC: ac:22:0b:9b:b3:b8
SSID: "belkin.eb5"
IP Address: 192.168.2.28
LinkSpeed: 72
NetworkId: 16
Rssi: -45
SupplicantState: COMPLETED
WiFi DHCP Status
IP Address: 192.168.2.28
Netmask: 0.0.0.0
Default Gateway: 192.168.2.1
DNS 1: 192.168.2.1
DNS 2: 0.0.0.0
Server IP: 192.168.2.1
Lease Duration: -1


Info from Desktop:



Windows IP Configuration

Host Name . . . . . . . . . . . . : Dreamland
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : Belkin

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . : Belkin
Description . . . . . . . . . . . : Intel(R) Ethernet Connection (2) I218-V
Physical Address. . . . . . . . . : D0-50-99-2F-A3-E7
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::9516:ddb:ecfa:1395%3(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.2.32(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Tuesday, July 21, 2015 12:31:33 PM
Lease Expires . . . . . . . . . . : Friday, August 27, 2151 7:30:11 PM
Default Gateway . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.2.1
DHCPv6 IAID . . . . . . . . . . . : 63983769
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-24-09-4E-D0-50-99-2F-A3-E7
DNS Servers . . . . . . . . . . . : 192.168.2.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter VirtualBox Host-Only Network:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter
Physical Address. . . . . . . . . : 0A-00-27-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::fdba:eac:3dfc:ddf7%7(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.56.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 168427559
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-24-09-4E-D0-50-99-2F-A3-E7
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{A53EE0E7-3F6B-4AC7-8AC4-73ACFEC30C39}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6ab8:c45:3e14:9ead:27ed(Preferred)
Link-local IPv6 Address . . . . . : fe80::c45:3e14:9ead:27ed%5(Preferred)
Default Gateway . . . . . . . . . : ::
DHCPv6 IAID . . . . . . . . . . . : 134217728
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-24-09-4E-D0-50-99-2F-A3-E7
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.Belkin:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : Belkin
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes



Ping tablet from PC

Pinging 192.168.2.28 with 32 bytes of data:
Reply from 192.168.2.28: bytes=32 time=121ms TTL=64
Reply from 192.168.2.28: bytes=32 time=139ms TTL=64
Reply from 192.168.2.28: bytes=32 time=44ms TTL=64
Reply from 192.168.2.28: bytes=32 time=58ms TTL=64

Ping statistics for 192.168.2.28:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 44ms, Maximum = 139ms, Average = 90ms



Ping from tablet to PC failed. Assuming that's the problem, but I have no idea where to go from there.

Network topology:

[bjNwxL4] 



Dave Thaler

Registered:
Posts: 452
Reply with quote  #13 
Thanks, that explains exactly what's going on.  Your server has two interfaces with different addresses on different subnets.   It is both 192.168.2.32 on the same network as the Nexus, as well as 192.168.56.1 on the "VirtualBox Host-Only Network" which isn't connected to anything. 
So when you ping the Nexus from the server, it's using 192.168.2.32 and works fine.  If you tried pinging the Nexus from 192.168.56.1 ("ping -S 192.168.56.1 192.168.2.28") it would fail just like trying to ping 192.168.56.1 from the Nexus fails.  That's because 192.168.56.1 has no connectivity to the rest of that network (you'll notice there's no default gateway on the VirtualBox interface).

This should work fine if you try to instead connect to 192.168.2.32 from the Nexus.  Artemis acting as a server actually listens on all IP addresses (that's the 0.0.0.0 in the netstat output you verified).  The problem is that the Artemis server UI just displays one IP address of the machine and isn't smart enough to pick the right one here.  But that's just a display issue.  Tec made the same point in another thread and he's exactly right.   So for your topology you should ignore what the Artemis UI displays and use the address on the Ethernet interface of your server: 192.168.2.32 according to the output you sent.
grungydan

Registered:
Posts: 7
Reply with quote  #14 
Wow, it seems so obvious once you point it out. [biggrin]

Thanks a bunch for the help. It indeed connected right up once I told it to use .2.32 and I was flying past DS1 at warp bajillion by accident right away. 

I'll dedicate our maiden flight to you. 

Thanks Tec as well for the assist. 
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.