Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
cxfAtheus

Registered:
Posts: 322
Reply with quote  #1 
I have been working on bringing in different 3d models to the game. I have finally figured out how to UV map a ship properly. It looks great in game. Now I'm trying to get the engines and beams coming out of the proper locations.

I tried using the ship editor to get coordinates, but can't seem to figure it out. Is there a way to get coordinates from deled, or is the ship editor the best route?

How do I use the ship editor better?
ryleyra

Registered:
Posts: 3,007
Reply with quote  #2 
I'm not sure about how you would get coordinates from other modeling software. They're probably not in the same coordinate system as Artemis, meaning you'd have to do a conversion.

As for the Ship Editor, I've used it to get coordinates on the ship's surface quite a few times. IIRC, you just use the directional keys (arrow keys, I think) to move the yellow vector around the surface. The vector always comes from the center of the model, and the coordinates shown are where the vector crosses the surface. For beams, the vector represents the center of the arc of the beam, so you want to make sure the vector is in the same plane as the ship's direction of travel for best results.

For engines, I'm guessing that you can ignore the direction of the vector. Just try to put the starting point of the vector where you want the engine or maneuvering trail to come out. Record those coordinates, and use them in your ship definition.

In some cases, I think, you have to rotate the vector along the Z coordinate 180 degrees to make the vector point backwards. Just hold down the "up" button until the vector comes around to the back of the ship and then move it left and right.
Fish Evans

Registered:
Posts: 361
Reply with quote  #3 
in DeleD use the co-ordinates in the program, just hover the mouse on the appropriot point and read the co-ords in the window header of that particular view, I tend to put the engin point a little out from the ship, but the beams should be inside the hull or you will not be able to hit them in manual fire.
cxfAtheus

Registered:
Posts: 322
Reply with quote  #4 
Thanks for the ideas guys

@Fish

I figured out earlier today that the xyz coordinates in Deled translated perfectly. They were actually much easier to find that way.
cxfAtheus

Registered:
Posts: 322
Reply with quote  #5 
Followup issue. I'm getting the beams and engines in the right places. However, I'm also trying to replace alien vessels. I can't get maneuver and impulse points to show up. I'm assuming those are the spots viewable in manual beams for the weapons officer to target. I put in the location where I would like those to be on the model, but I can't get anything to show up in game.

Is there a trick to this?
MarkBell

Avatar / Picture

Administrator
Registered:
Posts: 1,955
Reply with quote  #6 
The points need to be inside the physical model, I think.  If the ShipEditor picks out a point <45,35,-132> try reducing all the numbers by 1 <44,34,-131> - that should have it in about the right spot but inside the mesh itself.  I think that is what Fish Evans was talking about above.
__________________
Note - this is in no way intended to be an official position of Thom or Artemis, as I am not an official representative of the creator or game.
cxfAtheus

Registered:
Posts: 322
Reply with quote  #7 
I'll give that a shot. I've been trying to place them on the surface, so far. Hopefully your idea works.

EDIT: Well. No joy. I've been trying to put them everywhere and haven't had any luck. This is standing in the way of completely overhauling all of the models in the game...not to mention driving me nuts. (aaaaargh)
Fish Evans

Registered:
Posts: 361
Reply with quote  #8 
the manovering points do not show up ingame, there is a bug where by Drone points get marked as maneuvering points, I cant be sure but the order of points listed might have an effect as well.
cxfAtheus

Registered:
Posts: 322
Reply with quote  #9 
After reading your comment, I went and tested a vanilla version of 2.2 and saw maneuvering only listed on a single ship (Torgoth, which I'm not changing...yet), and never saw impulse listed for anyone.

So, I guess for now, it's not something I can worry too much about. Just plug them where I think they should go, and maybe someday they'll show back up.
ryleyra

Registered:
Posts: 3,007
Reply with quote  #10 
Try testing in 2.0 or 2.1 to ensure you have them in the right place. Is targeting with the Gun Sight bugged in 2.2? That's something that should be reported.
cxfAtheus

Registered:
Posts: 322
Reply with quote  #11 
I tested out V 2.11 and didn't see any impulse or maneuver on any ships in manual targeting mode. I didn't check every single type of enemy ship, but I checked at least one of every single race.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.