Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
archadious

Registered:
Posts: 3
Reply with quote  #1 

I'm having trouble with the 2.2 upgrade.  I've tried running it as Admin and I'm setting it up for all users on the system.  However, after the install when I try running Artemis I get a dialog box that reads:

Artemis.exe has stopped working


Not a very helpful message.   Anyone else experience this problem?  How do I correct it?

I'm running Windows 8.1 x64on a Intel NUC with 8MB memory.  Earlier versions of Atemis, and the 2.1 Demo, run just fine.

-A

ryleyra

Registered:
Posts: 3,007
Reply with quote  #2 
Well, I would have expected a reply by now. I'm not sure I can help, but I'll try.

Try uninstalling Artemis and reinstalling from scratch. Also, you say you have the 2.1 demo, do you have the stock game for 2.0? Because if you are trying to upgrade from 1.7 or earlier, the 2.2 patch will not work. Do not try to patch the demo.
archadious

Registered:
Posts: 3
Reply with quote  #3 

Re-installing the program does not help.  I still end up with the same error message.  I tried downloading the version 2.2.0 installer and running it.  After installation it crashes with the same message.

I have the bridge license but can not enter it as the program crashes.  This is the full version not the demo.

Thanks.

-A
Newcommerin

Avatar / Picture

Registered:
Posts: 190
Reply with quote  #4 
I am no pro, but sometimes a stupid question brings a terrifique answer.

You have the full version of Artemis 2.X?
If Not: The 2.2.0 is just an update for version 2.X. It won't work for itself and not with versions before 2.0.

You installed the update in the same directory as the full version?
No? It won't work.

Did you bought it on steam?
Yes? You can't update it, it updates itself.

As far as I know, you are never asked for a license key by the software. Are you sure it isn't something else?

__________________
Sorry, English is not my native language, I am German.
(* I wish I would live in America, I wish I would... *)
Any mistakes you can find, you can keep and with the spelling mistakes you can cook you an alphabet soup.

My Artemis Homepage: https://star-ship-academy.jimdo.com/
BigEd

Registered:
Posts: 188
Reply with quote  #5 
You can also try running it in "Compatibility Mode".  Right click on the Artemis.exe in the installation folder and on the Compatibility tab try some of the other options.  I've had the same and other similar problems with Artemis as well, and was never completely able to solve the problem.  So I've switched to Ubuntu linux using WINE to run Artemis for the main ship.  I still use Windows 7 and 8 with Artemis but sometimes, Artemis just doesn't want to work...
User McUser

Registered:
Posts: 123
Reply with quote  #6 
You might also want to check your computer's memory using the built-in Windows memory tester (C:\Windows\System32\mdsched.exe) or the very lovely Memtest 86+ (http://memtest.org/).
Sandman

Registered:
Posts: 145
Reply with quote  #7 
I'll chime in here rather than start a new topic.

I'm having trouble running 2.2 in multiple windows. All of the clients seem to crash a few seconds after the game starts. This is with both stock and modded installs.  I am using windows 10.

I can run 2.1.1 with six windows open.  It's my preferred method of testing things because I can have all of the stations and a mainscreen open on my desktop without having to go into the cold garage and turn everything on.

I haven't tried 2.2 in the garage on separate machines yet, but hope to soon.

At the very least, I'd like to know if anyone else is having this problem with 2.2. Thanks.

__________________
CDR Callisto "Sandman" Bold
Executive Officer of TSN Harbinger
Shipwright of Project Harbinger (Seattle WA)
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.